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Electronic Portfolios in the Classroom 
What are portfolios?  
 

Electronic Portfolios are a creative means of organizing, summarizing, and 

sharing artifacts, information, and ideas about teaching and/or learning, along with personal and 

professional growth. The reflective process of portfolio development can be as important as the final 

product. In many cases, they are used as part of faculty and student evaluation along with other 

assessment tools such as standardized tests. A portfolio is a sampling of the breadth and depth of a 

person's work conveying the range of abilities, attitudes, experiences, and achievements.  

Activity 1: Planning Your Portfolio  

Planning your electronic portfolio is your first step. First you must decide on the type and purpose of your 
electronic portfolio, you will need to decide what to include in it. In this activity, you will plan what to 
include in your electronic portfolio and plan your Home Page or index.html page.    

When selecting portfolio content be sure to consider the following questions:  
1. What do you plan to accomplish with this task?  
2. How do you plan to get there? 
3. What are the strategies you will use to accomplish the task? 

The sample portfolio (Al’s Electronic Portfolio) is a Poetry Portfolio and shows a variety of work 
done by Al in his English class. Al's Poetry Portfolio contains the following items: 

• Poetry Comparison  
• Morning Poem  
• Poem Analysis  
• Tangled Jealousy  

This is how Al's home page looked when it was completed. 
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Like Al's, your Home Page should clearly define the purpose and contents of your portfolio. It 
will also provide links to other content pages within your site. How will you connect the 
Home Page to the additional Web pages that contain your portfolio items? Here is a brief 
sketch depicts the layout of the portfolio. 

 

Activity 2: Overview of Dreamweaver 

In this activity, you will become familiar with the workspace and features of Dreamweaver. 

Start Dreamweaver to see some of the most commonly used components: 

 

The Document Window 
The Document window appears when you open a new page. This is the area where you design 
your page.  
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The Document Tool Bar  
The Document tool bar contains buttons and pop-up menus that provide users choices on 
viewing options (code or design views), a title field where users can title their pages and 
operations that allow users to preview their pages in a browser.  

Dreamweaver has two types 
of workspaces. A workspace 
for coders and a workspace 
for designers. The code view 
is for users more inclined to 
code pages by hand. The 
designer view is for users 
who prefer to design web 
pages graphically. While you 
develop your electronic 
portfolio, you will be using 
the design view.  

 
When you create your pages, you can enter a name for each page in the 'Title' field.  

 

 

Preview allows you to preview your pages in a browser of your 
choice.  

Viewing Modes 

Dreamweaver lets you have four ways of looking at any document. From the design view , all of the 
WYSIWYG editing options are directly available (bolding, bullets, styles, etc.). However, there may be 

times when you wish to edit the raw HTML code directly. The code view lets you look directly at the 
code 'behind the scenes' should you wish to edit or add instructions in this manner. The code and design 

view places the code view in a window above the design view, allowing you to view both 
simultaneously. Finally, Dreamweaver also lets you preview your work as it will appear in an Internet 

browser by selecting the preview mode . In preview mode, links that jump within your computer are 

made active. From the Document tool bar, switch between design view and code view . Try the 

code and design view as well. Finally, click on the preview mode and select the browser of your 
choice. Return to design view.  

The Insert Bar 
The Insert bar has buttons to insert objects into your document. The same objects are in the insert 
menu.  

During this tutorial we will be 
creating hyperlinks, inserting 
tables and images. 

 

Panel Groups  
Panel groups are sets of panels docked together under one heading.  (see next page) 
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The Files panel shows you files that make 
up your site and lets you manage those 
files. It also provides a view of all the files 
on your local disk.  

Click on the Collapse button to close the 
panels on the right side of the document 
window. Click on the button again to open 
the panels.  

 

 

Property Inspector Panel 
The Property Inspector lets you view and change a number of properties for selected objects.  

 

The Property panel above shows the properties that appear in the Property Inspector when 
text is selected. As in any word processor, you may change your font style, size, color and 
justification. 

 

This Property panel shows how the Property Inspector changes when an image is selected. 
Notice the image appears at the top left corner of the panel. The source (Src) shows the name 
of the file ‘sunhead.jpg.' 

If you were working on a table, the Property inspector would show table attributes.  
To show or hide the Property inspector: Choose Window > Properties.  
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Activity 3: Preparing to Make a Web Site 

A Web site typically consists of a number of individual web pages linked together. In addition to text, the 
pages often have images and perhaps sound or video. In order to make the organization of your site 
easier, it is important to place all your files (pages, images, etc.) into one directory or folder. In this 
activity, you will set up local site and root folders in Dreamweaver to serve as organizers for your 
portfolio. 

1. Launch Dreamweaver. Choose Site > New Site. Setting up a site, will enable all of your files to be 
saved and stored in the folder you have created for that purpose.  

2. A new window entitled “Site Definition for Unnamed Site 1” will appear.  (The Basic tab in the left 
corner should already be selected.  If not, select it.)  In the “What would you like to name your site?” 
field, enter the name you wish to give your site.  This will replace “Unnamed site 1.” Let’s call this 
site “portfolio.” 

 
 

3. Click Next. This will take you to the next screen where you will be asked if you want to use server 
technology.  The radio button “No, I do not want to use server technology” should already be 
selected.  If not, select it, and click Next. 

 

 
 

4. You will then be asked where you want to store the files on your computer.  You can enter the path 
name or click on the yellow folder to the right and browse to the location you want.  I suggest you 
keep your folder on the desktop, so you can find it easily. 

 

 
 

5. Click Next. You will then be asked “How do you connect to your remote server?”  From the drop 
down list select “None.” 

 

 
 

6. Click Next.  You’ll see a window with a summary of the choices you made.  Click Done.  You now 
have a folder in Dreamweaver in which you can create your web site! 
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Activity 4: Creating the Home Page 

Your home page will act as a title page for your electronic portfolio introducing the site to 
viewers and providing links to the items you have selected to include. In this activity, you 
will create the home page for your portfolio using a table and some text. 

1. Launch Dreamweaver and be sure the 
'Portfolio' site folder is selected. Each time you 
launch Dreamweaver, you start with an 
untitled basic page.  
 

 

 
2. Title your document in the title field on the Document tool bar by typing your name 
followed by Electronic Portfolio (e.g. Al's Electronic Portfolio).  

3. Save and name your Home Page: 
 File > Save As...>index.htm  

A convention used on the Internet is that the first 
page of a Web site is entitled index.htm or 
index.html.  

To create a basic page layout using a table: 

Al used a table to layout his Home Page because it 
gives additional formatting options when working with text and images. Tables consist of three 
basic components: Rows (run horizontally), Columns (run vertically), and Cells (the 
container created by intersecting rows and columns).  

A table's structure and appearance can be easily modified. You can use a table to separate the 
parts of a page and then format each part differently.  

4. Look at the Home Page layout you sketched out in Activity 1. Like Al's, the Home Page for 
your portfolio should have four main parts: 

• your school's name  
• your name, grade, class and portfolio title  
• a portfolio description  
• a list of the portfolio items (4 to begin)  

5. Click in the document window of index.htm (your home page). Click the Table button 

on the Insert Bar or choose Insert > Table. A pop-up window appears where you can 
define the structure of your table. To create a table as in Al's portfolio, type the following 
information: 



  Page 7 of 16 

Rows: 4 
Columns: 1 
Width: 80% 

Cell Padding: 0 
Cell Spacing: 0 

Border: 0 

 
Click OK. 

  

 

A table with four rows appears in the Document window. In the Property inspector, name 
the table Home Page and align the table in the center of your document.  

 

6. Save your work by choosing File > Save. 

To Create Text in a table: 

1. Click in the first row of the table. Type your school's name. (You will go back later to 
format the text). Next click in the second row and type your name, grade, class and 
portfolio title.  

Hint: If you want your name and titled displayed on two separate lines that are close together, press Shift + Enter. 

2. In the third row of the table type your introduction and clearly state the purpose of the 
portfolio.  
 

3. Use the fourth row to type the list of items you decided to place in your portfolio. Make 
each item a separate line by pressing Enter or Shift + Enter for a single space after each 
line of text.  

Here is a sample of Al's Home Page.  
Below are instructions on how to format your 
text (change the font style, size, color and 
alignment).  
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To Change Text Properties: 

One way to enhance the readability and attractiveness of your Home page is to change the 
properties (size, font, boldfacing, and so on) of the text.  

Click on the first row of your table and choose Edit > Select All to select all of the text within 
that cell. A bold black line will outline the cell.  

 

At the top of the Property inspector, select a font style from the second pop-up menu. In the size pop-up menu, select 
a larger size for your school's name. You may want to change the color of the font by clicking in the box next to the 
size pop-up menu. You could align the text to the centre by using the text justification buttons on the top right of the 
Property inspector panel.  

Change the text size and justification in the second, third and fourth rows so that it is easily 
read by your audience.  Save your work by choosing File > Save. 

Preview your Home Page in 
a browser by selecting the 
browser of your choice from 

the preview mode on 
your Document tool bar. You 
can also press F12. 

 

Your Home Page is almost complete! You will learn how to add hyperlinks to link your pages 
together in Activity 9.  
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Activity 5: Creating Content Pages 

In this activity, you will build your first content page using a 'nested' table. You will create 
three other content pages and copy the 'nested' table from your first content page onto your 
other three pages. This way, they will all look the same.  

Each content page will begin with four parts (2 rows and 2 columns) laid out in a table as 
shown here: 

 

1. To create the content page structure chose File > New > Basic Page > Click Create. 
 

2. This will be the first content page, such as the Poetry Comparison in Al's sample portfolio. 
 

3. Choose File > Save as and give your page an appropriate title. Al titled his page 
Poetry_Comparison.  

Also place the title field on the 
Document tool bar.  

 

4. Click the Table button on the Insert Bar or choose Insert > Table. A pop-up window 
appears where you can define the structure of your table. To create a table as in the 
sample portfolio, type the following information: 

Rows: 2 
Columns: 2 
Width: 100% 
Cell Padding: 0 
Cell Spacing: 0 
Border: 0  

5. Click OK. A table with two rows and two columns appears in the Document window. In the 
Property inspector, align the table in the center of your document.  
 

6. Click in the left cell of the first row and 
drag the mouse down so that the two 
cells that make up the first column are 
selected. In the bottom of the Property 
inspector, change the column width (W) 
to 15%. Select the right cell of the first 
row and drag the mouse down so that the 
two cells that make up the second 
column are selected. In the Property 
inspector, change the column width (W) 
to 85%.  
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7. Click in the left cell of the top row. In the Table Property inspector, choose a background 
color. Click the box next to the Bg label at the bottom of the panel. The color palette 
opens. Select a color that complements your font color. For example, Al's background is 
#003399.  
 
You may want to change the background color of the right cell in the top row as well. 
When choosing a background, be sure to chose a color that complements the font color for 
readability.  
 

8. In the top right cell, type your name and the name of your portfolio (e.g. Al's Poetry 
Portfolio). Reformat the font style, size, color and justification to suit your portfolio (review 
in Activity 4). It is important to stay consistent with the choices you made on your Home 
Page. Consistency ensures the reader that he or she is still in the same site.  
 
Again, your page should look similar to the sample:  

 

Nest a table inside another:  

Now you're ready to create the structure for each of the work samples you chose to include in 
your portfolio. Each work sample in your portfolio should include the actual work and 
additional information - a description, the date completed, and your thoughts - to help the 
portfolio reader understand the work. To create a structure to your page, we will nest one 
table inside of another. It will look something like this: 

 

Click in the right cell of the bottom row.  In the Property inspector, select Center from the 
Horizontal (Horz) pop-up menu and select Top from the Vertical (Vert) menu.  
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Your cursor should now be blinking at the top center of the cell. Click the Table button on 
the Insert Bar or choose Insert > Table. Enter the following: 

Rows: 4 
Columns: 1 
Width: 75% 
Cell Padding: 0 
Cell Spacing: 0 
Border: 0 

Click OK 
A new four row table appears inside the bottom right cell.  

 

Click in the first row of the nested table. Type 'Date Completed'. 

 In the second row, type 'Description'. 
 In the third row, type 'My Thoughts'. 
 The fourth row will remain empty for now but will eventually contain your portfolio sample. 
 Format the text you added (change the font style, size, and color).  

Type the titles of your portfolio work samples in the bottom left cell. We will add the actual 
links later. You may also want to add your picture. Your first page should look something like 
this: 
 

 

Save your work.  
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Activity 6: Copy a Table to Other Content Pages 

In this activity, you will copy the table you created in Activity 5, on your first portfolio page, 
with all its contents to three other pages. This is an efficient way to create pages that look the 
same.  

Choose File > New to create a second portfolio page.  

Choose File > Save As and give your new page an appropriate title. Al titled his second page 
Morning_Poem. Be sure to type the title of the document in the title field on the Document tool 
bar.  

In the next section, the following will be described. You will need to open your first page, 
select and copy the larger table, and paste it into your second page.  

There are a couple of ways this could be done.  

If you previously had your first page open and did not close it, you should notice just above 
the Property inspector, each of your pages are represented by titled tabs.  

 

You could toggle between the two pages by clicking on the tabs.  

If the tabs do not appear, you could open your original content page by pulling down the File 
Menu > Open > locate and open the page. The tabs should now appear at the bottom of the 
Document window.  

From your original content page, select the larger table by clicking on the outside of it from 
within the Document window. You will know it has been selected by the dark box that will 
appear around the outside of it.  

Or click on the first instance of <table> to select the 
larger table and the nested table. Notice how the <table> 
becomes bold when you click it.   

Choose Edit > Copy, or press Ctrl + C (Windows) to copy the table.  

To open your second content page, click on its tab just above the Property inspector. Click 
inside the Document window and choose Edit > Paste, or Ctrl + V (Windows), to paste the 
table into your second content page. 

Save your work.  

Create your third and fourth page by repeating the steps above. Don't forget to give your third 
and fourth pages appropriate titles when saving. Al called his third page Poem_Analysis and 
his fourth page Tangled_Jealousy. 
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Al's site folder now contains five .htm files. His 
index page which is his Home Page, 
introducing his portfolio items, and each one of 
his content pages (Morning Poem, Poem 
Analysis, Poetry Comparison, and Tangled 
Jealousy). The Home Page will provide links to 
each content page (see Activity 9).  

Each content page has the same structure for 
consistency. This was easily done by copying 
and pasting a table from the original content 
page to every additional page.  

There are two additional files in Al's site folder 
(Al1.gif and PrinceAndrew.gif). Both are image 
files. Al's teacher provided his with a copy of 
the school's logo in which Al inserted in the top 
row of his Home Page. Al also had his picture 
taken with a digital camera and inserted the 
image in the top left corner of his pages. For 
more information on inserting graphics, see 
Activity 8.  

Check your site folder to make sure all your 
files are saved in the proper location.  

 

You will now need to add content to each one of your pages. Activity 7 describes how to add 
previously created text and Activity 8 describes how to insert images on your content pages. 
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Activity 7: Inserting an Image 

In this activity, you will insert an image into your document.  

Images may be included as a record of a presentation, an achievement, an art work, etc.  

Al wanted to place his picture on the pages of his portfolio. A classmate took a picture of Al 
with the school's digital camera. The image was downloaded, saved in a shared area on the 
school's network and resized.  

Be sure that the image you are going to insert into your portfolio is 
saved in an area that is accessible to you and that it is small enough 
in size that it will not create unnecessary wait time for viewers as it is 
downloading.  

Open the page you would like to include the image on. Place your 
cursor where you would like your image. Click on the image button 

on the Insert bar or chose Insert > Image. Navigate to the 
location where your image is saved and double click on the image file. 
A window will appear asking if you would like the image placed in your site folder. Remember 
that all files must be saved within this site folder or they will not appear to viewers on your 

web site. Ask Dreamweaver to copy the file there for you by clicking . 

To change the properties of the image: selecting the image. Notice the properties in the 
Property inspector change according to whether you have an image selected, text selected or 
a table selected. The Property inspector lets you change the 
properties of what ever object you have selected on your page. If 
you would like your image aligned in the center, you could chose 
to 'align center' in the Property inspector.  

Save your work by choosing File > Save.  

Be sure that your image file is located in your site folder. Preview 
your Home Page in a browser by selecting the browser of your 

choice from the preview mode on your Document tool bar. Or 
by pressing F12. 
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Activity 9: Linking Pages 

In this activity, you will create all the links between the various pages in your site by using 
the Property inspector and the Point to File icon.  

Part One - To Create the Links on the Home Page 

1. Open index.htm. 

2. Highlight the text for the first item in your portfolio list, such as Morning Poem.  

3. In the Property inspector, click the Point to File icon and drag the link arrow up to the site 
map until it draws and outline around Morning Poem.htm (or your first portfolio content page). 
Release the mouse. The text, Morning Poem, should now be blue and underlined, indicating 
that it has a link. 

 

Check the link address in the Link text box in the Property inspector.  

 

 

4. Repeat steps 2 and 3 to create a link for each portfolio item on the Home Page.  

5. Choose File > Save to save your work.  

Part Two - To Create the Links on the Content Pages 
 
1. Open the first content page (e.g. Morning Poem).  

2. In Activity 5 you should have typed the titles of your portfolio work samples in the bottom 
left cell of your table (e.g. Home, Morning Poem, Poetry Comparison, etc.). We are now going 
to link each of these pages together.  

Highlight the text that will direct readers to your Home Page (index.htm).  

3. In the Property inspector, click the Point to File icon and drag the link arrow up to the site 
map until it draws and outline around index.htm (your Home Page). Release the mouse. The 
text, Home, should now be blue and underlined, indicating that it has a link.  

Check the link address in the Link text box in the Property inspector.  
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4. Repeat steps 2 and 3 to create a link for each portfolio item on your first content page. 
When linking pages, be sure to link the first content page to itself (e.g. Al linked the text 
Morning Poem to the Morning_Poem.htm file using the Point to File icon).  

5. Choose File > Save to save your work.  

6. Highlight all of the text that have now become links on your first content page. Choose Edit 
> Copy or press Ctrl+C (Windows), to copy the links. Now you're ready to copy these links 
to the other pages.  

7. Open the second content page and place your cursor in the left bottom cell. Choose Edit > 
Paste or press Ctrl+V (Windows), to paste the links into the cell.  

8. Choose File > Save to save your work.  

9. Repeat steps 7 & 8 for each content page in your portfolio.  

To Test the Links 

After you have created the links, it is important to test them.  

1. Open index.htm. 

2. Preview your Home Page in a browser by 
selecting the browser of your choice from the 

preview mode on your Document tool bar.  
 

3. Go through the entire site and check your links. If a link does not work or goes to the wrong 
page, close the browser, open the problem document, and inspect the links.  

Congratulations! You have a working electronic portfolio! 

 


